Главная » Записи с тегом "Требования"

Рубрики с меткой ‘Требования’

Установка phpBB

Процесс установки phpBB3 проходит просто и быстро, рассмотрим его по этапам:

  1. Сначала нужно сопоставить системные требования phpBB3 с характеристиками сервера, на который Вы хотите произвести установку. Необходимые системные требования описаны в статье «Требования для установки phpBB 3″.
  2. Скопируйте файлы на сервер.
  3. Через браузер зайдите на Ваш будущий форум, перейдите на закладку «Инсталляция» и кликните «Перейти к следующему шагу».
  4. На странице «Совместимость системных требований» показано соотношение системных требований phpBB3 и параметров Вашего сервера. Если требования совпадают, кликните «Начать процесс инсталляции». Если не все системные требования удовлетворяются, обратитесь к Вашему хостеру. Если на сервере не поддерживается требуемая версия PHP или отсутствуют СУБД, то форум не будет работать. Вы можете воспользоваться специальным хостингом, оптимизированным для форумов и CMS, в том числе для phpBB3.
  5. Введите данные базы данных:Тип базы данных — выберите используемую Вами СУБД, в большинстве случаев на хостинговых серверах используется MySQL. Вы можете обратиться к хостеру, чтобы узнать характеристики СУБД.Имя сервера БД или DSN — домен, на котором расположена БД. Чаще всего — localhost. Если сервер БД является не локальным, то имя сервера БД необходимо узнать у хостера.

    Порт сервера — обычно это поле заполнять не нужно, т. к. используется порт по умолчанию, но если для подключения к базе данных Вам потребуется прописать порт сервера, Вы можете уточните его у Вашего хостера.

    Имя базы данных — название созданной Вами базы данных через панель администрирования хостинга.
    Читать далее »

Требования для установки phpBB 3

Для успешной установки и последующей работы phpBB3 необходимы следующие основные требования:

Сервер, работающий на любой операционной системе, с поддержкой PHP.

Поддержка одной из следующих баз данных SQL:
MySQL 3.23 или выше (поддерживается MySQLi)
PostgreSQL 7.3 или выше
SQLite 2.8.2 или выше
Firebird 2.0 или выше
MS SQL Server 2000 или выше (напрямую или через ODBC)
Oracle

PHP 4.3.3 или выше с поддержкой базы данных, которую вы собираетесь использовать.
Читать далее »